Leyra - AppGrid: intermittent API request timeout in Spain – Incident details

All systems operational

AppGrid: intermittent API request timeout in Spain

Resolved
Operational
Started almost 9 years agoLasted 1 day
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    The faulty CloudFront edge in Madrid has been fixed by Amazon. Traffic from users in Spain is now going again through that edge, since July 6th 18:50 UTC. We are monitoring closely the latency and traffic metrics in the region to make sure the issue is completely resolved.

  • Identified
    Identified

    The faulty CloudFront edge in Madrid is not returned anymore for customers in Spain which should prevent timeout issues. We are still in communication with AWS to get exhaustive information about the issue and working towards its complete resolution.

  • Investigating
    Investigating

    We're investigating some API requests timing out on their way to the AWS Cloudfront Edge location in Madrid (before they reach AppGrid) together with AWS Support.