Leyra - OTT Flow™ - Issues with Favorites and Watch History – Incident details

All systems operational

OTT Flow™ - Issues with Favorites and Watch History

Resolved
Degraded performance
Started about 7 years agoLasted about 6 hours
Updates
  • Update
    Update

    During an update of the system, an API was changed in a way that the Content-Type of the API response changed. When Accedo One make a new release all API responses and headers are checked for backwards compatibility to make sure there is no change in the behaviour. A human error made one api call being missed in this test list. The API was functioning correctly and there were no errors in the logs but there was a difference in the Content-Type of the response. Accedo One Product Team rolled back the configuration that caused this change and released a new version that was stable again. We will add backwards compatibility tests for the missing API so any kind of changes in the response are caught in the future.

  • Resolved
    Resolved

    The problem has been resolved.

  • Monitoring
    Monitoring

    A fix has been deployed and we will continue to monitor the traffic and logs.

  • Identified
    Identified

    We've identified the problem and are working on a resolution.

  • Investigating
    Investigating

    We're currently experiencing issues with reading and updating Favorites and Watch History in all OTT Flow™ apps. We are investigating the problem and will provide further updates here.